Problem2477--格式化输出-竖式计算练习

2477: 格式化输出-竖式计算练习

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 285  Solved: 161
[Status] [Submit] [Creator:]

Description

输出两个数a,b(1<=a,b<=999)
在屏幕上输出a+b的竖式,试编一程序,实现这个功能。

Input

两个正整数a,b(1<=a,b<=999)

Output

输出a+b的竖式(宽度为8)

Sample Input Copy

18 870

Sample Output Copy

      18
+    870
--------
     888

HINT

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int a,b;
    cin>>a>>b;
    cout<<setw(8)<<a<<endl;
    cout<<"+"<<setw(7)<<b<<endl;
    cout<<"--------"<<endl;
    cout<<setw(8)<<a+b;
    return 0;
}

Source/Category

 基础C